Название: Обработка табличной информации - учебное пособие (Бычков М.И.)

Жанр: Информатика

Просмотров: 987


3. встроенные функции excel

 

Возможность вычислений по формулам и мгновенное получение результата – отличительные черты электронных таблиц (табличных процессоров). Формулы могут иметь числа, ссылки на ячейки, содержащие данные или другие формулы.

Для сокращения записи сложных вычислений в формулах часто используют встроенные функции Excel, возвращающие вычисленное значение. Каждая из функций имеет имя, после которого в круглых скобках задаются значения одного или нескольких аргументов, разделяемых точкой с запятой.

В качестве аргументов могут выступать выражения, в том числе и другие функции. Если функция не содержит аргументов, то после имени вводятся только круглые скобки.

Excel содержит большое число встроенных функций. Все они по назначению разбиты на следующие группы (категории): Финансовые, Дата и время, Математические, Статистические, Ссылки и массивы, Работа с базой данных, Текстовые, Логические, Просмотр свойств и значений.

Из функций чаще других используется функция СУММ, автоматически вычисляющая сумму значений ячеек выделенного диапазона. Эту функцию можно запустить на выполнение с помощью кнопки  (автосуммирования) на стандартной панели инструментов.

Для суммирования содержимого ячеек несмежных диапазонов последние выделяют при нажатой клавише Ctrl и при записи функции СУММ отделяют друг от друга точкой с запятой, например =СУММ(A1:A3;B1:B3).

Для суммирования содержимого ячеек, имеющих одинаковый адрес, но расположенных на смежных листах книги Excel, используется составной адрес, образуемый указанием диапазона листов и адреса суммируемых ячеек, отделенных восклицательным знаком, например =СУММ(Лист1:Лист4!A1).

Ввод может быть значительно упрощен при использовании кнопки , расположенной на стандартной панели инструментов и запускающей подпрограмму Мастер функций. Мастер функций – это электронный конструктор, с помощью которого может быть сгенерирована любая из встроенных функций.

Функции, которые используются в качестве аргументов в других функциях, называют вложенными.